什么都分享
以及,记录自己的故事
正在载入当前位置天气信息……

通过javascript判断浏览器版本

有时候建站会遇到浏览器兼容性的问题,奈何IE浏览器对html5支持不是特别好,看这后劲也没什么起色,为了保证网站的访问体验,某些情况下有必要引导用户使用最新技术的浏览器,比如Chrome和Firefox。

首先确保你已经引用了jquery:

<script type="text/javascript" src="js/jquery.min.js"></script>

然后在</head>标签前插入以下代码:

<script type="text/javascript"> 
var name = navigator.appName;
if (name == "Microsoft Internet Explorer") { 
document.writeln("<div class=\"IE-warning\">您使用的是IE</div>");
};
</script>

代码解释:用JavaScript来判断用户使用的浏览器程序名称是Microsoft Internet Explorer,如果是,那么通过document.writeln输出一个div。当然这里也可以加入版本判断:var version = navigator.appVersion,这里的version就是浏览器版本了。

然后使用css控制这个由js写的div样式:

.IE-warning{
position:fixed;
top:0px;
z-index:1000;
width:100%;
height:20px;
background-color:orange;
color:white;
text-align:center;
}

最后就完成了,在使用IE的浏览器访问网站时,在顶部会有橙色横幅置顶提醒。当然,这些样式你可以自己修改。

打赏
本文遵守创作共享 BY-NC-ND 4.0协议,转载前请先联系作者。绯末博客 » 通过javascript判断浏览器版本
分享到: 更多 (0)

评论 抢沙发

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏